Jump to content
Touring Motor Gliders Association (TMGA)
  • Tachometer Question


    Ethan Graham
     Share

    Abstract: Something went a little awry with my tachometer today. It's not exactly that it doesn't work - it indicates up to 1,000 RPM, but no higher.


    Subject: Tachometer question
    From: "Finbar Sheehy" <finbarsheehy@yahoo>
    Date: 9/2/07 2:45 PM
    To: Taifun17E@yahoogroups.com

    Hi everyone,

    Something went a little awry with my tachometer today. It's not exactly that it doesn't work - it indicates up to 1,000 RPM, but no higher. Below 1,000 RPM it changes in the correct general direction with changes in power setting, but I can run the engine up to a good roar without the needle on the tach going above 1,000 RPM.

    In anticipation of trying to point the mechanic in the right direction, does anyone have any thoughts on where to look for the problem? (I thought I noticed an electrical/burning smell after starting the engine, before I noticed the tach problem, but that could have been some unrelated smell from outside the airplane, it was very faint.)

     Share


    User Feedback

    Recommended Comments

    There are no comments to display.



    Join the conversation

    You can post now and register later. If you have an account, sign in now to post with your account.

    Guest
    Add a comment...

    ×   Pasted as rich text.   Paste as plain text instead

      Only 75 emoji are allowed.

    ×   Your link has been automatically embedded.   Display as a link instead

    ×   Your previous content has been restored.   Clear editor

    ×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...